Skip to main content

Cara Menghubungkan Jaringan Virtual di GNS3 ke internet

#1 Sharing Akses Internet ke VirtualBox Host-Only Ethernet Adapter

Buka control panel > Network and Sharing Center > Change adapter settings, sharing network adapter yang memiliki akses internet ke adapter virtualbox host-only Ethernet. Contoh pada gambar, network adapter yang memiliki akses internet adalah Wireless Network Connection lalu di sharing ke virtualbox host-only ethernet adapter. 


Setelah Akses internet di sharing, pastikan VirtualBox Host-Only Ethernet Adapter sudah di setting IP Address. Contoh pada gambar di setting IP Address 192.168.137.1 Subnet mask 255.255.255.0

Baca Juga


#2 Buat Topologi Jaringan dan Konfigurasi Router di GNS3

Buka aplikasi GNS3 lalu tambahkan perangkat jaringan yang digunakan seperti gambar di bawah, untuk PC client yang digunakan bisa di sesuaikan dengan yang teman - teman gunakan. 


Devices Interface Terhubung ke IP Address
Cloud 1 nio_gen_eth : R1 (FastEthernet0/0) 192.168.137.2/24
R1 Serial0/0 R2 (Serial0/0) 10.1.1.1 /24
R2 Serial0/0 R1 (Serial0/0) 10.1.1.2 /24
R2 FastEthernet0/0 SW1 (Port 1) 192.168.1.1 /24
Windows XP 2 Ethernet0 SW1 (Port 5) 192.168.1.10 /24
Windows XP 3 Ethernet0 SW1 (Port 6) 192.168.1.11 /24

#2.1 Konfigurasi Cloud

Klik kanan icon cloud, klik Configure. Di tampilan cloud configuration pada bagian Generic Ethernet NIO (Administrator or root access required) pilih VirtualBox Host-Only Network lalu klik Add


Klik Apply dan klik OK

Lalu hubungkan setiap perangkat jaringan yang sudah kita tambahkan sebelumnya dengan interface sesuai dengan tabel di atas.



#2.2 Konfigurasi IP Address R1

Klik kanan router R1, pilih Start. Lalu klik kanan lagi router R1, pilih Console. Pada tampilan console yang muncul, setting ip address dan default routing di router R1 dengan menjalankan peritah berikut ini secara berurutan.

R1#configure terminal
R1(config)#interface fastethernet0/0
R1(config-if)#ip address 192.168.137.2 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#ip route 0.0.0.0 0.0.0.0 192.168.137.1
R1(config)#exit
R1#ping 192.168.137.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.137.1, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 20/25/40 ms
R1#

Pastikan ping ke VirtualBox Host-Only Network Adapter sukses seperti di atas, lalu jalankan perintah ini secara berurutan.

R1#configure terminal
R1(config)#ip domain-lookup
R1(config)#ip name-server 8.8.8.8
R1(config)#exit
R1#ping google.com
Translating "google.com"...domain server (8.8.8.8) [OK]

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.217.27.14, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 68/72/76 ms
R1#

Setelah menjalankan perintah di atas, pastikan ping ke google.com sukses. Berikutnya setting ip address interface serial yang menghubungkan router R1 ke R2 dan membuat routing RIP dengan menjalankan perintah berikut secara berurutan.

R1#configure terminal
R1(config)#interface serial0/0
R1(config-if)#ip address 10.1.1.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#no auto-summary
R1(config-router)#network 192.168.137.0
R1(config-router)#network 10.1.1.0
R1(config-router)#exit
R1(config)#

#2.3 Konfigurasi IP Address dan Routing Router R2

Klik kanan router R2, pilih Start. Lalu klik kanan lagi router R2, pilih Console. Pada tampilan console yang muncul, setting ip address dan routing RIP di router R2 dengan menjalankan perintah berikut ini secara berurutan.

R2#
R2#configure terminal
R2(config)#interface serial0/0
R2(config-if)#ip address 10.1.1.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#interface fastethernet 0/0
R2(config-if)#ip address 192.168.1.1 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#router rip
R2(config-router)#version 2
R2(config-router)#no auto-summary
R2(config-router)#network 192.168.1.0
R2(config-router)#network 10.1.1.0
R2(config-router)#exit
R2(config)#
R2(config)#ip domain-lookup
R2(config)#ip name-server 8.8.8.8
R2(config)#

#2.4 Konfigurasi NAT Overload di Router R1

Jalankan perintah berikut ini agar jaringan yang ada di GNS3 dapat terhubung ke internet.

R1#
R1#configure terminal
R1(config)#interface serial0/0
R1(config-if)#ip nat inside
R1(config-if)#exit
R1(config)#interface fastethernet0/0
R1(config-if)#ip nat outside
R1(config-if)#exit
R1(config)#access-list 1 permit 10.1.1.0 0.0.0.255
R1(config)#access-list 1 permit 192.168.1.0 0.0.0.255
R1(config)#ip nat inside source list 1 interface fastethernet0/0
R1(config)#

#2.5 Tes Koneksi Internet dari Router R2

Lakukan ping ke google.com dari router R2 dan pastikan suskses seperti dibawah.

R2#
R2#ping google.com
Translating "google.com"...domain server (8.8.8.8) [OK]

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 74.125.130.102, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 36/63/88 ms
R2#


#3 Setting IP Address dan Tes Koneksi Internet dari PC Client

Start PC client yang ada di GNS3 lalu setting ip address sesuai dengan tabel di atas lalu gateway dan dns sesuaikan seperti pada gambar di bawah. Lalu lakukan tes ping google.com untuk tes koneksi internet dari PC client, jika reply maka kita sudah berhasil menghubungkan jaringan Virtual di GNS3 ke internet...Silahkan tulis komentar jika teman - teman bingung dengan konfigurasi di atas :) 



Comments

Popular posts from this blog

Cara Konfigurasi OSPF di Cisco Packet Tracer

Cara Konfigurasi OSPF di Cisco Packet Tracer – OSPF atau Open Shortest Patch First merupakan sebuah routing protokol IGRP (Interior Gateway Routing Protocol) yang hanya dapat digunakan dalam di jaringan internal suatu organisasi atau perusahaan yang kita memiliki hak administrasi terhadapt jaringan tersebut. Pada artikel ini akan di perlihatkan bagaimana Cara Konfigurasi OSPF di Cisco Packet Tracer.

Baca JugaPengertian dan Perbedaan Internet, Intranet Berdasarkan JangkauannyaKonfigurasi Routing EIGRP di GNS3Cara Konfigurasi EIGRP di Cisco Packet Tracer Cara Konfigurasi Routing Static Router Mikrotik di GNS3Cara Konfigurasi Routing Dinamis RIP di Cisco Packet Tracer
Topologi dan IP Address Buat topologi jaringan dengan interface dan ip address sesuai dengan gambar dan tabel yang ada di bawah. Atau jika teman – teman ingin menghemat waktu, dapat mendownload topologi jaringan nya disini
Setting IP Address Setelah topologi jaringan di buat seperti gambar di atas, setting ip address untuk …

Pengertian, Jenis & Kelebihan VLAN (Virtual LAN)

Pengertian VLANVLAN (virtual LAN) adalah suatu model jaringan yang membagi jaringan secara logikal ke dalam beberapa vlan yang berbeda. VLAN tidak terbatas pada kondisi fisik jaringan seperti pada LAN, vlan dapat di konfigurasi secara virtual tanpa harus melihat kondisi peralatan. Oleh sebab itu, VLAN memiliki fleksibilitas di dalam pengaturan jaringan dan memudahkan administrator jaringan dalam membagi jaringannya sesuai dengan fungsi dan kebutuhan keamanan jaringan tersebut. Baca juga artikel tutorial komputer lainnya Pengertian Routing & Jenis - Jenis Routing


Cara kerja VLANVLAN diklasifikasikan berdasarkan metode (tipe) yang digunakan, baik menggunakan port, MAC address dan lain - lain. Semuainformasi yang mengandung penandaan/pengalamatan suatu vlan (tagging)di simpan dalam suatu database (tabel), jika penandaannya berdasarkanport yang digunakan maka database harus mengindikasikan port-port yangdigunakan oleh VLAN. 
Untuk mengaturnya maka biasanya digunakanswitch/bridge yang ma…

Cara Mengaktifkan dan Menonaktifkan System Restore di Windows 7

Cara Mengaktifkan dan Menonaktifkan System Restore di Windows 7 – System Restore adalah sebuah fitur di Microsoft Windows yang mengizinkan pengguna untuk mengambalikan keadaan komputer ke waktu tertentu yang sudah di tetapkan, mengembalikan keadaan komputer yang dimaksud file sistem, aplikasi yang di install, Windows Registry dan sistem setting. Fitur ini sangat berguna jika terdapat error pada windows atau komputer terasa lambat karena mungkin sudah banyak terinstall aplikasi yang sudah tidak terpakai, maka dengan fitur system restore ini kita dapat mengembalikan windows ke waktu tertentu seperti saat pertama kali windows di install. Fiture System Restore sudah ada dari Windows ME, Windows XP, Windows Vista, Windows 7, Windows 8, Windows 8.1, Windows 10 dan secara default system restore dalam keadaan disabled jika kita belum pernah menggunakannya. Berikut adalah langkah – langkah cara Mengaktifkan/enable System Restore di Windows 7.

Baca JugaMelakukan Backup Hardisk dan Partisi Mengg…